iCash 7.5.9 release


Staff member
New iCash v7.5.9 has been released today. This is a free update for all v7 users with an update plan.

iCash is an easy-to-use, full featured and multi-purpose Personal Finance software for Macintosh and Windows intended to help you control your personal finances, keeping track of incomes, expenses, credits, debts and Banks transactions for you. No needs to know about accounting or even care about it! iCash lets you know where your money comes from and to where it goes with just a few clicks.

What's new in this release:

- Fix: Issue with multiple transaction editor not showing the comboboxes menus.
- Fix: Return key not handled properly in Comment and Project fields.
- Fix: Totals not visible next to 'Transaction' when selecting several transactions.
- Fix: Key shortcuts using the shift key no longer blocked by transaction input fields.
- Fix: Payee, comment and project fields no longer deleted when going thru fields.
- Fix: Switching panels no longer reset the transaction entry panel.

Don't forget to read our small tutorial about adding transactions to iCash, how to use Budgets and how to import transactions from a Bank statement.


New Member

I have just installed the latest update on macOS Sierra and no matter which way I try to open the program it tells me that there is a problem with the application. The error is as follows:

iCash can't be opened. You should move it to the Trash.

Then when I click on the help file for the error it tells me that:

The app’s authorization has been revoked

There may be a problem with this app. Although the app was signed by an identified developer, the certificate for the app has been revoked, and it cannot be opened.

Check with the Mac App Store or the software developer to see whether there is an updated version of this app.

Is this something you can help with.



New Member

I have restarted multiple times and I have just downloaded the current version via a different browser and I still get the same error.



New Member

I have managed to fix the issue using the command below within the Terminal App:

sudo xattr -r -d com.apple.quarantine /Applications/iCash/

The issue appears to be that the Gatekeeper system is quarantining the app which stops the system from running it. The above command removes the quarantine status and allows the app to run.

Not sure why Gatekeeper thinks it needs to quarantine the app but at least I have a fix.