No sending mails

stevieb

New Member
Hi!

MLM seems to run properly. So far I am testing only subscribe_single_fixed.php

Duplicates are detected.
Unsubscribe works, but no confirmation mail is sent and no text is displayed, instead blank page.
Subscribe leads to a blank page, no email sent.

Error log says:
[Wed Apr 11 11:27:58.139041 2018] [:error] [pid 55812] [client 137.208.48.75:53508] PHP Fatal error: require_once(): Failed opening required 'Mail.php' (include_path='.:') in /Library/Server/Web/Data/Sites/oegv.net/newsletter/FTP/lm/lm_functions.php on line 2101

There is no "mail.php" required....

Cheers, Stephan

ps. went though many of the posts here. All I found let to the present situation. Before the subscription process let to the renewal of a empty subscribe_single_fixed.php
 

stanbusk

Administrator
Staff member
This is because you have activated mail authentication in lm_prefs.php. As a result the 'PEAR mail package' is being used, well, MLM tried to use it but the package is not present on your system. Is it really necessary to use authentication?

--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 

stevieb

New Member
Thank you for your support!
Are there any plans to provide user accounts? No urgent need, just curious.
cheers, stephan
 
Hi,
my server needs an authentication so I need to check $smtp_auth = true; in the lm_prefs file and I got the error message described above : Failed opening required 'Mail.php'

ho shall I do ?

best
samuel
 
Hi Stan,
thanks for your reply. Yes they do need authentification. The told me "ave recently updated our spam filtering and the SMTP authentication is now required for the php mail ". The php code semmes not to work, they did a php file test that worked. I'm not used at all to php code but it seems that the "lm_functions.php" file is not communcating with teh server (hostpapa). I tried to change that code to match their example but it's catastrophic, I don't understand tha language, sorry. Any help would be great.
best
Samuel
 
Hi,
I'm wondering if somebody has this problem with mail authentification ti subscribe to a newsletter because we're not able anymore to have people subscribe sinc our sever needs authentification. I'm not used to php language so if anyone has an idea about what to change in the script (or somewhere else) that would be nice, we can't have anymore new friends here !
 
Hi,
I don't really understand your question. My ISP told me they now need authentification. They did a test with this ph code here below I paste it. Sorry but I really are not used to this language and I don't know what to do with that :


<?php
require_once "Mail.php";
$from = "Samuel <hostpapa@instantsvideo.com>";
$to = "Elina <nomPrenom@hostpapa.com>";
$subject = "testing the email service";
$body = "this is just a test. please ignore it.";
$host = "hp235.hostpapa.com";
$smtpPort = 25;
$username = "hostpapa@instantsvideo.com";
$password = "*12345678";
$headers = array ('From' => $from,
'To' => $to,
'Subject' => $subject);
$smtp = Mail::factory('smtp',
array ('host' => $host,
'port' => $smtpPort,
'auth' => true,
'username' => $username,
'password' => $password));
$mail = $smtp->send($to, $headers, $body);
if (PEAR::isError($mail)) {
echo("<p>" . $mail->getMessage() . "</p>");
} else {
echo("<p>Message successfully sent!</p>");
}
?>

thanks
 

stanbusk

Administrator
Staff member
This is PHP code to use PEAR. PEAR is a PHP library to mail authentication. MLM supports PEAR but PEAR has to be available on the server. The lm_Prefs.php file allows you to turn PEAR on and off.

--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 
Hi, thanks for your reply. What I found on my lm prefs is that. Sorry to paste the hall thing but I really don't know this language. Where should I turn PEAR on ?

// -- SMTP Host ----------------------------------------------------------------
// To use only if MLM fails sending messages because the server needs authentication

$smtp_auth = true; // Activate or deactivate SMTP Authentication
$smtp_host = "the host"; // The SMTP host address
$smtp_username = "myMAIL"; // The SMTP account user name
$smtp_password = "myPASSWORD"; // The SMTP account password


// -- Debugging ----------------------------------------------------------------

$mlm_debug
 

stanbusk

Administrator
Staff member
Yes, this is it.

$smtp_auth = true;
$smtp_host = "the host"; <- Replace "the host" with your server address
$smtp_username = "myMAIL"; <- Replace "myMAIL" with your account username
$smtp_password = "myPASSWORD"; <- Replace "myPASSWORD" with your account password

--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 
ok, so this seems correct, that's good news. But why is this not working ? The ISP told me its working with their script using PEAR and when I have this parameter on in lm pref… when we subscribe, it's just an empty white page and nothing happens… any idea ?
 
Hi,
yes it looks like there are semicolon at each line of the script but this not something I wrote, it's the lm_prefs file installed by the software, I just fill in the email address, password and change "false" to "true" and did no other changes at all.
 
Top