MLM installed but Web Interface Login Fails

zebedee999

New Member
I've been happily using MBM and updating its global Blacklist manually. But now I want to use MLM to manage the Blacklist with Unsubscribe and to check who opens my emails.

While I have seemingly successfully installed MLM (using Plain Text), I get a message at the end saying:

A file named “lm_settings.php” already exists in the destination. Do you want to replace it? (See attachments)

I have tried both options (Skip and Replace) but get the same result that says the installation is complete.

I then click on the Tool button in MLM Preferences and select Web Interface I get the login window. I enter my user id and password but the login fails.

When I click on Tool button and select Diagnose I get:

MLM 3.2.0 diagnose ran on 2020-02-07 at 05:21:43
request_uri = https://www.scottpartnership.com/scripts/lm/lm.php?cmd=diagnose&pwd=••••••••••••••••
path_to_script = https://www.scottpartnership.com/scripts/lm/lm.php
working_directory = /home/••••••••••••••••••/public_html/scripts/lm
mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0755
imports permissions = 0755
templates permissions = 0755
requests permissions = 0755
lists permissions = 0755
localreq doesn't exist! traffic permissions = 0755
by_delivery permissions = 0755
by_recipient permissions = 0755
1 list(s), 0 recipient(s), deliveries

Can anyone tell me what I’m doing wrong please and what I need to do to be able to log in correctly.

Thanks
Keith
 

Attachments

Last edited:

zebedee999

New Member
Hi Stan,
As you may have notice, I'm a complete novice when it comes to this sort of thing.
I made the mistake of entering my email address and password when it should have been my MLM username and password - now I can log in ok.
I then decided to take your advice and use MySQL to set up on my iMac.
The long and short of it is I can not upload any lists to MLM from the MLM login page.
On selecting Upload I do this.
MLM Lists Upload.png
The result is always the same:
MLM Lists - Zero.png
Clearly I am missing something wrong but I just don't understand what it is.
Below are my settings in the lm_settings.php.
If you can throw some light on this for me I would be very very grateful.
Keith
lm_settings.php.png
 

Attachments

stanbusk

Administrator
Staff member
Have you run the MLM diagnostics again? Is everything fine?
Note that your file should have this format:

Firstname1<tab>Lastname1<tab>Company1<tab>E-mail address1<linebreak>
Firstname2<tab>Lastname2<tab>Company2<tab>E-mail address2<linebreak>
Firstname3<tab>Lastname3<tab>Company3<tab>E-mail address3<linebreak>
...

Any other format will not work. When you upload directly from inside MaxBulk Mailer, this format is used automatically.

--
Subscribe to our Youtube Channel and watch our tutorials!
Follow maxprog.com on Facebook | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 

zebedee999

New Member
Hi Stan,
I am trying to load an existing list from inside MBM - see below.
Screenshot 2020-02-12 at 09.49.01.png

I select the list in MBM and go to the Recipients drop down menu at the top of screen and hit Upload to MLM.
This is what I get, so I can't progress any further.
Clearly I'm doing something wrong but I'm still very ignorant of what it is.

Screenshot 2020-02-12 at 09.52.14.png

This is the diagnostics I've just requested.
MLM 3.2.0 diagnose ran on 2020-02-12 at 04:59:44

request_uri = https://www.scottpartnership.com/scripts/lm/lm.php?cmd=diagnose&pwd=••••••••••••
path_to_script = https://www.scottpartnership.com/scripts/lm/lm.php
working_directory = /home/keithscott/public_html/scripts/lm

mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0777
imports permissions = 0755
templates permissions = 0755

#1 mysqli_connect( localhost, keithscott, •••••••••••••••••••••••••, TSP )
-> Connection error :) )
-> Check your server address and credentials in lm_settings.php
 

zebedee999

New Member
Hi Stan,
I'm beginning to lose hair over this :)
MLM, I am convinced, is installed correctly and working fine. Even though when I go through the upload process it still says no recipients were uploaded. I am equally convinced that MySQL is correctly installed.
In your instruction file "How to install MLM on your server" it says in Step 1, part 4, that if you don't have a database created then just enter a name and MLM will create it for you. Unfortunately this has not happened for me.
Over the weekend I found another part of MySQL Community Server that follows on from the original installation - MySQL Workbench, which I have now installed.
This link is what I have been following for instructions, although I only got as far as creating an empty "Schema":
Below shows the MLM diagnostics and the relevant part of lm_settings.php.
I've also attached a variety of screen shots from the MySQL and Workbench installation.
Please understand that I am a complete novice when it comes to MySQL so I would be extremely grateful if you could tell me exactly what I need to enter and where because I am totally lost here.
Thanks again.
Keith


MLM Diagnostics:
MLM 3.2.0 diagnose ran on 2020-02-18 at 09:16:33
request_uri = https://www.scottpartnership.com/scripts/lm/lm.php?cmd=diagnose&pwd=HDS09192324
path_to_script = https://www.scottpartnership.com/scripts/lm/lm.php
working_directory = /home/keithscott/public_html/scripts/lm

mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0777
imports permissions = 0755
templates permissions = 0755

#1 mysqli_connect( localhost, keithscott, mypassword, TSPcontacts )
-> Connection error :) )
-> Check your server address and credentials in lm_settings.php

MLM
lm_settings.php
$use_mysql = '1'; // 0 = Raw Text files 1 = mySQL Database
$dbhost = 'localhost'; // mySQL Host Name
$dbusername = 'keithscott'; // mySQL User Name (For Full access!!)
$dbuserpass = 'mypassword'; // mySQL User Password (For Full access!!)
$dbname = 'TSPcontacts'; // mySQL Database Name
 

Attachments

Last edited:

stanbusk

Administrator
Staff member
You are installing MLM on your local computer? Why don't you install it on your webserver? MLM was designed to be installed on a web server. Apart from that, why port 22? Port 22 is reserved SSH port. You could also try to use your machine IP address instead of 'localhost' just in case. Those are the things I would try first.

--
Subscribe to our Youtube Channel and watch our tutorials!
Follow maxprog.com on Facebook | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
-
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 

zebedee999

New Member
Hi Stan,
My apologies. The MLM settings mentioned above are from the lm_settings.php file installed on my web server. They are the details I entered for MLM to access MySQL - as detailed in your notes.
This is where MLM is installed: https://www.scottpartnership.com/scripts/lm/lm.php
The answer to you comment about Port 22 is simply that this is where the MySQL installation put it all on its own - I never had to enter anything except my password.
I have tried my IP address: 192.168.0.15 but cannot get a diagnostic from it - the page just hangs - never shows any details. I also tried my public IP address but got the same result - nothing. I have now put it back to localhost. At least it gets a diagnostic.

MySQL is installed locally on my iMac. After installation I expected MLM to be able to create the database as the instructions suggest in your setup guide.
Only since installing MySQL Workbench have I been able to look at the details of the MySQL installation. But as I've mentioned, this is totally alien to me, which is why I'm desperate for some help in any settings that may need changing.

Below are the diagnostics and lm_settings.php. I would be extremely grateful if you could offer any help at all on what I need to change to make things work.

Or should I try the plain text route instead. I have five lists containing 3,600 addresses between them.

Thanks
Keith


MLM Diagnostics:

MLM 3.2.0 diagnose ran on 2020-02-19 at 04:45:53

request_uri = https://www.scottpartnership.com/scripts/lm/lm.php?cmd=diagnose&pwd=mypassword
path_to_script = https://www.scottpartnership.com/scripts/lm/lm.php
working_directory = /home/keithscott/public_html/scripts/lm

mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0777
imports permissions = 0755
templates permissions = 0755

#1 mysqli_connect( localhost, keithscott, mypassword, TSPcontacts )
-> Connection error :) )
-> Check your server address and credentials in lm_settings.php


lm_settings.php:

<?php


// -- Access data & Notifications ----------------------------------------------



$admin_id = 'keithscott'; // Your administrator ID

$admin_password = 'mypassword'; // Your administrator password



// -- Default settings ---------------------------------------------------------



$defaults_language = 'en'; // Default language en = English, fr = French, de = German, es = Spanish, it = Italian, nl = Dutch



// -- Your email address, name and web address ---------------------------------



$admin_err_addr = 'mail@scottpartnership.com'; // The address where internal error notifications has to be sent

$admin_address = 'mail@scottpartnership.com'; // The administrator email address

$admin_name_full = 'Keith Scott'; // Your name or you company/organization name

$admin_name_short = 'Keith Scott'; // Short version of you name or you company/organization name

$admin_webAddress = 'https://www.scottpartnership.com';// Your web site address (http://www.mysite.com)



// -- Storage Type -------------------------------------------------------------



$use_mysql = '1'; // 0 = Raw Text files 1 = mySQL Database



// -- mySQL List/Stats Handling Settings ---------------------------------------

// Set the following parameters if you have selected to use mySQL above



$dbhost = 'localhost'; // mySQL Host Name

$dbusername = 'keithscott'; // mySQL User Name (For Full access!!)

$dbuserpass = 'mypassword'; // mySQL User Password (For Full access!!)

$dbname = 'TSPcontacts'; // mySQL Database Name



?>
 

stanbusk

Administrator
Staff member
Using plain text for storing data is a desperate option when you don't have access to mySQL. It is not recommended.

As I told you MLM is supposed to be installed on LAMP web servers. LAMP stands for LINUX+APACHE+MYSQL+PHP. Almost all web servers have this configuration.

I am not sure if MLM can be installed on a Mac as you have done. I have never tried this. Anyway MLM was created to run on a server online 24/24 since when you send a message you will get MLM connection all the time, which means your Mac and Network should be available 24/24 as well.

Anyway there error you get is still a credential error. Can you even connect to the database with Sequel Pro? The settings Sequel Pro uses are very similar to MaxBulk Mailer's.

--
Subscribe to our Youtube Channel and watch our tutorials!
Follow maxprog.com on Facebook | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 

zebedee999

New Member
Hi Stan,
I can assure you that MLM is installed on my web server.
Only MySQL Community Server is installed on my Mac, which is where it says to install it.
My problem is getting them to talk to each other.
As you can see from the current diagnostic below from MLM, it shows where it is installed but that it cannot contact MySQL.
All it tells me is that there is a connection error
This is where I need some help.
Thanks
Keith

MLM 3.2.0 diagnose ran on 2020-02-22 at 03:44:22

request_uri = https://www.scottpartnership.com/scripts/lm/lm.php?cmd=diagnose&pwd=••••••••••••••
path_to_script = https://www.scottpartnership.com/scripts/lm/lm.php
working_directory = /home/keithscott/public_html/scripts/lm

mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0777
imports permissions = 0755
templates permissions = 0755

#1 mysqli_connect( localhost, keithscott, mayfordg10gu220pp, TSPcontacts )
-> Connection error :) )
-> Check your server address and credentials in lm_settings.php
 
Top