MLM blank page

after a change of internet provider I had to reconfigure Maxbulk Mailer but I can't have any access to Mailing List. I do have access to the mage with "show list" but when I click on it I just have blank. Also when I want a diagnostic from the software or want info : blank page. I did chmod everything to 705, resintal many times mlm, did download a version I found on the forum, tried all kinds of password, user account, etc… blank page. Is it maybe obsolete ?
Thanks if any idea, it's been a long day


Staff member
Sorry, 755 or 705? The lm folder and all includes folders should have the 755 privileges.
Yes I tried all modes, same result. When I check for diagnostic I get "Error - Your password is wrong." But I can connect with this password to the main MLM interface. Did check database password, user, etc… I have no idea… I hope you do !
I dont' know what is "diagnostic" connecting to. I can access to mlm with a browser but when I want to see the list I got a blank page so I suppose it's the mySQL?
I just check and creat again a user with mysql and password but same problem. I don't know what to write on the lm-settings file under // mySQL Host Name, I did try my webstite, or 'localhost or another address I found following some tutorials but nothing working.


Staff member
You will have to ask your server admin, but the connection function used is mysqlicconnect()


hostSpecifies a hostname or an IP address
usernameSpecifies the MySQL username
passwordSpecifies the MySQL password
dbnameSpecifies the default database to be used

that function can take 2 optional parameters
mysqlicconnect(host, username, password, dbname, port, socket)

portOptional. Specifies the port number to attempt to connect to the MySQL server
socketOptional. Specifies the socket or named pipe to be used

But they are rarely used.
thanks for your reply but I don't understand what I have to ask: I have to ask if they use "mysqlicconnect()" for their database ? I don't understand a thing about this language, sorry, I try to understand but it's really difficult for me. If they don't use this function ""mysqlicconnect()" they have to tell me what I need to put in the "lm_settings.php" document ?


Staff member
I try to explain you in case they ask you about that. It is simple, MLM uses the standard mysqlicconnect() function to connect to MySQL database. That functions take parameters, are the parameter correct? Just check them.
They did reply and test the configuration , they told me : "nous recommandons en effet 755 pour les répertoires mais de placer 644 pour les fichiers. " That means to put each file in 644 and folders at 755 and it worked ! The only problem is when I try "diagnostic" in maxbulk I stille get error password but that is less anoying.
The only output I have when asking a "diagnostic" is "Error - Your password is wrong."
When I ask for info I get :
MLM version: 3.2.3

PHP version: 8.0.28 (Safe mode OFF)
max_execution_time = 1800 seconds
max_input_time = 360 seconds
memory_limit = 4096M
post_max_size = 512M
upload_max_filesize = 512M
display_errors = off
register_globals =

path_to_script = https://www.*** /lm/lm.php
working_directory = /home/*** /public_html/lm

total lists = 2
total recipients = 418
total deliveries = 80

MLM folder permissions = 0755

mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0755
imports permissions = 0755
templates permissions = 0755

mySQL Host: Localhost via UNIX socket
mySQL Server: 10.6.12-MariaDB(10.6.12)
mySQL Client: mysqlnd 8.0.28
mySQL Protocol: 10
mySQL Charset: utf8


Staff member
All look correct. The password you have to use is the one listed in the lm_settings.php file, $admin_password
thanks for checking. But I check and check the password, they are the same on maxbulk soft and in lm_settings.php , I don't understand.
Hi, yes, I just did change password of the user that has access to the database on the cPanle and on lml.settings… same issue.


Staff member
There is no relation between $admin_password and your database password. $admin_password is just for accessing the MLM script. It is the same password you can find in the MaxBulk Mailer settings, second panel.
thanks for your reply. I can't make it work, did change password many times, it looks simple. Is that correct : $dbhost = 'localhost' ?