• Next Maxprog online event is scheduled to go live soon!

    You can attend the event here: live.maxprog.com
    You can already ask questions on the very same page.

    You can also add the event to your calendar by clicking on Add to Calendar
    or click on the YouTube button to subscribe to our channel.

Lost information in comments

PauloMoreno

New Member
There are some bug in comments because don't have a limit when you type comments, but after save, when I consult information I've losted part of comments.

See image attached ...

Could you help me?

Thanks
 

MonHawk

Member
Hi, I am suddenly getting corrupted comments too. Having used iCash for years - I suddenly now have some transactions with all sorts of strange characters in the comments, and other transactions with comments that look like bits of other comments joined up.

I've tried to do the usual stuff of checking the data etc.... It reports no errors at all.

I'm finding this very worrying as I totally rely on iCash and it seems my database is corrupt in some way - even if it only appears to be the comments at this stage.
 

MonHawk

Member
If it helps, I've done an XML dump.
For the strange characters, I have the following inside a record:

<f n="Transaction_Comment"><![CDATA[愀氀 爀甀]]></f>

When I go to that transaction inside iCash, and try to replace that comment with something else, it looks for a moment as though it has worked, but then reverts to those strange characters.

And I've seen that all my transactions with the strange mashed-up comments are all in a block of transactions immediately before this one with the strange characters.

I can manually fix this xml file, but can I start up a new iCash File with the fixed xml file?
 

stanbusk

Administrator
Staff member
iCash uses a SQL database with unicode UTF-16 encoding. This is internal to the library actually. You can rename the document with the '.vdb' extension and open it with the tool listed [URL https://valentina-db.com/en/valentina-studio-overview]here[/URL] (free version) and see what encoding you get for those comments.

Note that it is the very first time I hear about such problem.

To repsond to your question, yes, you can re-import a XML file and recreate the document.

--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 
Top