Connection to smtp server stalls after sending data.

dwickander

New Member
I sent mail fine about a month ago from my server, but now it hangs on the first address every time. Here is the connection log...

[01] 8/3 10:02:53 ~ Opening connection for delivery...
[01] 8/3 10:02:53 ~ Connecting to smpt.server.com Port:25
[01] 8/3 10:02:53 ~ Connected
[01] 8/3 10:02:53 220 smpt.server.com ESMTP Postfix
[01] 8/3 10:02:53 > HELO [111.11.11.11]
[01] 8/3 10:02:53 250 smpt.server.com
[01] 8/3 10:02:53 > MAIL FROM:<sender@domain.com>
[01] 8/3 10:02:53 250 Ok
[01] 8/3 10:02:53 > RCPT TO:<recipient@domain.com> [1/1]
[01] 8/3 10:02:53 250 Ok
[01] 8/3 10:02:53 > DATA
[01] 8/3 10:02:53 354 End data with <CR><LF>.<CR><LF>

I have contacted the owner of the smtp server I send thru and they show me connecting and then mysteriously getting disconnected....

this is there reply:
I do show connections at 08:46:26 and disconnects at 08:49:06 with the message of "lost connection after DATA".

Any help would be greatly appreciated.

Thanks!
 

TimGolobic

New Member
I am also having the same problem. Been using the same settings for literally a decade until this week when the problem started. Send one message, then times out, tries to re-connect 5 times, gives up. Stop, re-send, repeat. Log below.

01] 12/8 12:05:43 ~ Status: Opening connection for delivery...
[01] 12/8 12:05:43 --> Connecting socket [1] with 2 entries to smtp.aol.com:587 Port:587
[01] 12/8 12:05:44 ~ Status: Connected
[01] 12/8 12:05:44 220-mtaout-aam01.mx.aol.com ESMTP MUA/Third Party Client Interface
220-AOL and its affiliated companies do not
220-authorize the use of its proprietary computers and computer
220-networks to accept, transmit, or distribute unsolicited bulk
220-e-mail sent from the internet.
220-Effective immediately:
220-AOL may no longer accept connections from IP addresses
220 which no reverse-DNS (PTR record) assigned.
[01] 12/8 12:05:44 > EHLO [10.0.1.43]
[01] 12/8 12:05:44 250-mtaout-aam01.mx.aol.com
250-PIPELINING
250-SIZE 36700160
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
[01] 12/8 12:05:44 > AUTH LOGIN
[01] 12/8 12:05:44 530 5.7.0 Must issue a STARTTLS command first
[01] 12/8 12:05:44 > STARTTLS
[01] 12/8 12:05:44 220 2.0.0 Ready to start TLS
[01] 12/8 12:05:44 ~ Status: Connected
[01] 12/8 12:05:44 > EHLO [10.0.1.43]
[01] 12/8 12:05:45 250-mtaout-aam01.mx.aol.com
250-PIPELINING
250-SIZE 36700160
250-ETRN
250-AUTH PLAIN LOGIN XAOL-UAS-MB XOAUTH2
250-AUTH=PLAIN LOGIN XAOL-UAS-MB XOAUTH2
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
[01] 12/8 12:05:45 > AUTH LOGIN
[01] 12/8 12:05:45 334 VXNlcm5hbWU6
[01] 12/8 12:05:45 > (my user name removed for this post)
[01] 12/8 12:05:45 334 UGFzc3dvcmQ6
[01] 12/8 12:05:45 > ************
[01] 12/8 12:05:45 235 2.7.0 Authentication successful
[01] 12/8 12:05:45 > MAIL FROM:(my user name removed for this post)
[01] 12/8 12:05:45 250 2.1.0 Ok
[01] 12/8 12:05:45 > RCPT TO:(recipient user name removed for this post) [1/2]
[01] 12/8 12:05:48 250 2.1.5 Ok
[01] 12/8 12:05:48 354 End data with <CR><LF>.<CR><LF>
[01] 12/8 12:05:49 250 2.0.0 Ok: queued as A1E9D38000090
[01] 12/8 12:05:49 ~ Status: Stage 3 dispatch done [2/2]
[01] 12/8 12:05:49 ~ Status: Delay of 3s [00:00:03]
[01] 12/8 12:05:49 > QUIT
[01] 12/8 12:05:49 221 2.0.0 Bye
[01] 12/8 12:05:49 ~ Status: Stage 4 dispatch done [2/2]
[01] 12/8 12:05:49 ~ Status: Next Delivery in 00:00:03
[01] 12/8 12:07:54 *** SMTP TIME-OUT 1 - 120 s
[01] 12/8 12:07:54 --> Reconnecting attempt 1 of 5
[01] 12/8 12:09:54 *** SMTP TIME-OUT 2 - 120 s
[01] 12/8 12:09:54 --> Reconnecting attempt 2 of 5
[01] 12/8 12:11:54 *** SMTP TIME-OUT 3 - 120 s
[01] 12/8 12:11:54 --> Reconnecting attempt 3 of 5
[01] 12/8 12:13:54 *** SMTP TIME-OUT 4 - 120 s
[01] 12/8 12:13:54 --> Reconnecting attempt 4 of 5
[01] 12/8 12:15:54 *** SMTP TIME-OUT 5 - 120 s
[01] 12/8 12:15:54 --> Reconnecting attempt 5 of 5
[01] 12/8 12:17:54 *** SMTP TIME-OUT 6 - 120 s
[00] 12/8 12:17:54 ~ Status: [-]
[00] 12/8 12:17:54 ~ Status: Closing all streams
[00] 12/8 12:17:54 ~ Status: Creating report...
[00] 12/8 12:17:54 ~ Status: Sending report...
[01] 12/8 12:17:54 ~ Status: Opening connection for delivery...
[01] 12/8 12:17:54 --> Connecting socket [1] with 1 entries to smtp.aol.com:587 Port:587
[01] 12/8 12:17:55 ~ Status: Connected
[01] 12/8 12:17:55 220-mtaout-aan02.mx.aol.com ESMTP MUA/Third Party Client Interface
220-AOL and its affiliated companies do not
220-authorize the use of its proprietary computers and computer
220-networks to accept, transmit, or distribute unsolicited bulk
220-e-mail sent from the internet.
220-Effective immediately:
220-AOL may no longer accept connections from IP addresses
220 which no reverse-DNS (PTR record) assigned.
[01] 12/8 12:17:55 > EHLO [10.0.1.43]
[01] 12/8 12:17:55 250-mtaout-aan02.mx.aol.com
250-PIPELINING
250-SIZE 36700160
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
[01] 12/8 12:17:55 > AUTH LOGIN
[01] 12/8 12:17:55 530 5.7.0 Must issue a STARTTLS command first
[01] 12/8 12:17:55 > STARTTLS
[01] 12/8 12:17:55 220 2.0.0 Ready to start TLS
[01] 12/8 12:17:56 ~ Status: Connected
[01] 12/8 12:17:56 > EHLO [10.0.1.43]
[01] 12/8 12:17:56 250-mtaout-aan02.mx.aol.com
250-PIPELINING
250-SIZE 36700160
250-ETRN
250-AUTH LOGIN XAOL-UAS-MB XOAUTH2 PLAIN
250-AUTH=LOGIN XAOL-UAS-MB XOAUTH2 PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
[01] 12/8 12:17:56 > AUTH LOGIN
[01] 12/8 12:17:56 334 VXNlcm5hbWU6
[01] 12/8 12:17:56 > (my user name removed for this post)
[01] 12/8 12:17:56 334 UGFzc3dvcmQ6
[01] 12/8 12:17:56 > ************
[01] 12/8 12:17:57 235 2.7.0 Authentication successful
[01] 12/8 12:17:57 > MAIL FROM:(my user name removed for this post)
[01] 12/8 12:17:57 250 2.1.0 Ok
[01] 12/8 12:17:57 > RCPT TO:(my user name removed for this post) [1/1]
[01] 12/8 12:17:57 250 2.1.5 Ok
[01] 12/8 12:17:57 354 End data with <CR><LF>.<CR><LF>
[01] 12/8 12:17:58 250 2.0.0 Ok: queued as 4D5373800008C
[01] 12/8 12:17:58 ~ Status: Stage 3 dispatch done [2/1]
[01] 12/8 12:17:58 ~ Status: Delay of 3s [00:00:03]
[01] 12/8 12:17:58 > QUIT
[01] 12/8 12:17:58 221 2.0.0 Bye
[01] 12/8 12:17:58 ~ Status: Stage 4 dispatch done [2/1]
[00] 12/8 12:17:58 ~ Status: [-]
[00] 12/8 12:17:58 ~ Status: Finishing...
 

TimGolobic

New Member
I tried a minute, then 2 minutes, then 3 minutes, still times out after 5 tries.

But if I stop-send-stop-send-stop-send, it connects and sends 1 at a time right away. Also after the timeout alert and automatic re-start, that sends OK.
 
Top