Configuration error when installing MLM on ftp server, attached image

stanbusk

Administrator
Staff member
When you get errors during the installation the best will be to install the software manually. You can do that with a FTP software like FTP Disk, Transmit, Fetch, CoreFTP... First download the very last MLM release here: http://www.maxprog.com/goodies/mlm_pro_php.zip.

This how you have to proceed:

1.- Open the lm/lm_settings.php file with a text editor (Notepad on Windows or free TextWrangler on Mac OS).
2.- Edit the script settings and save (each setting is explained in the file). [1]
3.-
Upload the 'lm' folder to your FTP server (in your public folder). [2]
4.-
Use your FTP software to CHMOD the 'lm' folder to 777 (775, 755 or 705). [3]
5.-
Enter the 'lm.php' full URL and your user ID and password to MaxBulk preferences.
6.- If you have selected to use mySQL run the script with the 'Init' command:
http://<script_path_here>/lm.php?cmd=init&pwd=password

[1] The lm/lm_settings.php contains all the parameters you can change to customize the script to match your needs. When doing a manual installation it is important to open that file with a plain text editor like Notepad on Windows or TextWrangler on Mac OS.

[2] Never upload MLM to your home root folder if you have a specific folder for public html documents like 'public', 'html', 'public_html', 'web', 'www', 'httpdocs'. Just open the folder or any subfolder first!

[3] You can CHMOD a folder with your FTP software. For example with FTP Disk just connect to your server, select the 'lm' folder and either click on the 'Get Info' menu or use the Cmd-I on Mac OS or Ctrl-I on Windows. You will get a window with the file permissions at the bottom. Write the new number next to 'Unix:' and click on 'Apply'. Note that the 777 permissions work with most servers but it's possible your server doesn't allow them showing a FTP error as soon as you try to change them or an HTTP 'Internal Server Error' when you try to run MLM with your browser. In such case try 775, 755 or 705.

You can check whether MLM has been installed and is operating correctly either by running the diagnostics from the MaxBulk Mailer preferences second panel (Tool button > Diagnose) or by logging into it with your browser using your MLM ID and password (Tool button > Web Interface). Go to 'Lists', try to create a test list and try to add a recipient to that list. If you get an error, check the '../lm/lm_settings.php' file on your server. To log into MLM manually with your browser just use the full lm.php URL. Another way to check if MLM was installed properly is to run a diagnostic manually on your browser. Use following command:

lm.php?cmd=diagnose&pwd=YOUR_MLM_PASSWORD

If you get mySQL connection errors it is very likely because your mySQL settings stored in the lm/lm_settings.php file are wrong, especially the server address. Try 'localhost' or the server IP address.

--
Follow maxprog.com on Facebook | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 
Last edited:

lalval

New Member
Good;

I have done the configuration of a test server in Linux centos 7, the installation can already be done automatically, however, when I perform tests of sending mail it is not generating statistics, and if I perform the diagnostic tests from preferences of MAXBULK, this generates this message, attached image.
I am correcting the database error, but, although I do not select the MYSQL option and leave it as plain text, the program does not generate statistics.

1565189408341.png
 
Top