cannot upload list to MLM

Everything was working ok till today. First I updated from version 8.5 to 8.5.1 (maybe this is irrelevant but just in case I mention it). Second, although my list in question (call it A) was already uploaded, as I was also using in the past a manual way of people to remove themselves using the word 'remove' in the subject, I run the Bounce Handler, collected all the email addresses with 'remove' in a DELETE file, and then in Maxbulk Mailer I applied the DELETE file to A. As usual, the email addresses in the DELETE file were removed from A. Then I tried to upload the new version of A and MLM told me that it had removed all the email addresses from A except the ones that were in DELETE! In other words the opposite of what I wanted to do happened. Then I deleted this new A (that had only the deleted email addresses) and tried to make a new A from past Maxbulk files. Although I managed to do it in Maxbulk itself, when I try to upload the new file A I get the message "No recipients have been uploaded to the remote list 'A'. Check your list and try again. Make sure your list contains at least the "First name", "Last name", "Company" and "Email Address" columns in this order delimited by tabs. They can all be empty except the "Email Address" column."

I have seen other posts that complain about the same issue, but under different circumstances. I tried to extract the list A, pass it again through Extractor, everything is fine at the level of Extractor or Maxbulk but the MLM will not accept it. What can I do?

Please help if possible!

George
 

stanbusk

Administrator
Staff member
New version doesn't change anything about MLM not lists. All is exactly the same. The list of changes is available here: http://www.maxprog.com/site/misc/news_us.php?sku=4 Note that we also use MLM here for our web site and all works as usual. If you can reproduce a problem more than twice please send an exact list of steps so we can try to reproduce.
 
stanbusk said:
New version doesn't change anything about MLM not lists. All is exactly the same. The list of changes is available here: http://www.maxprog.com/site/misc/news_us.php?sku=4 Note that we also use MLM here for our web site and all works as usual. If you can reproduce a problem more than twice please send an exact list of steps so we can try to reproduce.
Thanks for your answer, but it only clarifies that the new version is in no way responsible for my problem. I tried to explain what I did and how I got the problem. Do you have any idea what I can do to get my list uploaded on MLM?

Regards
George
 
OK, it seems that the problem is not the particular list at all. I just created in Maxbulk Mailer a brand new list with just my name as a test. Then I tried to upload it to MLM, it does not work either from within Maxbulk Mailer or from the web based interface of MLM. In the first case I get the message I reported before and in the second case I get the message that "0 address(es) have been uploaded to 'Test'. MLM has found 0 duplicate(s) and 0 bad address(es).", even though the file has 1 address, mine.

Should I reinstall MLM?

George
 

stanbusk

Administrator
Staff member
Try to run the MLM diagnosis: it is:

mlm_full_path/lm.php?cmd=diagnose&pwd=your_mlm_password

What do you get? (If you post the output, replace your credentials with *)
 
This is what I get:

MLM 3.1.6 diagnose ran on 2015-10-27 at 19:40:05

request_uri = *
path_to_script = *
working_directory = *

mailqueue permissions = 0755
sqlqueue permissions = 0755
uploads permissions = 0755
imports permissions = 0755
templates permissions = 0755

#1 mysql_connect( dbserver.*, *, *, * )
-> Connection OK!

#2 mysql_select_db( * )
-> Database selection OK!

#3 mysql_query( SELECT * FROM `tbl_mlm_sub_req` WHERE `fld_sub` = '0' )
-> Query OK!

#4 mysql_query( SELECT * FROM `tbl_mlm_sub` WHERE `fld_list` = '' )
-> Query OK!

#5 mysql_query( SELECT * FROM `tbl_mlm_sub_clk` WHERE `fld_delivery` = '' )
-> Query OK!

#6 1 list(s), 0 recipient(s), 2 deliveries
-> No error found.

Lists (List Name | Total Recipients | Modification Date):
 
No I haven't, but the problem appears to be with MLM not with our web host system.
I mean, when MLM tells me it cannot upload the list because it doesn't have the fields it should have (which it does), what does the web host system have to do with this?

Maybe I should just delete the installation and re-install it. But it would be good to know what exactly went wrong so that I can avoid doing it again.
 
OK, I deleted completely the lm installation and the mySQL set up and reinstalled everything. But I still have many problems:

From inside MaxBulk mailer, when I try to move from one list to another, I get the message
"Error #103 - The URL is not valid." along with some URL that keeps changing. When I try to
upload the list to MLM, I get the same message and the "To List" option cannot be clicked so
that I can provide a destination name.

When I export the list and try to upload it from the web interface, I get the same message as
previously (0 addresses uploaded) and in my email I get a message with the following in the
subject line: "[MLM] Error creating the tbl_mlm_sub_req table in CreateSubscribtionRequestTable()"
However, my administrator checked and two tables were created in the database
Re-installing using plain text does not solve the problem as I still cannot upload anything on the MLM.

The only difference from before making the new installations, is that now if I produce a new list I can
upload it (only from the web interface). But this does not help much when I cannot use my old list with thousands of email addresses.

The whole thing is pretty a mess right now. :cry:
 

stanbusk

Administrator
Staff member
What you have to do is to contact your web hosting service so they can check why the MLM HTTP POST generates an error and what error it is. Based on that, the administrator can adjust the web server and PHP security settings. Those settings are the ones causing the problem.
 
We managed to sort out the problem. Indeed, it had to do with the permissions. Everything is working fine now. Thanks for all the help! :D

George
 

dysong3

Member
I thought I would continue this post rather than start a new one as I am having similar issues.

I can't upload to the MLM list from within MaxBulk Mailer using the menu item "Upload to MLM…". I get an error saying "An error occurred during the upload process.

The result of my diagnosis is :

MLM 3.1.6 diagnose ran on 2018-11-18 at 14:33:53

request_uri = *********.**
path_to_script = *********.**
working_directory = *********.**

mailqueue permissions = 0777
sqlqueue permissions = 0777
uploads permissions = 0777
imports permissions = 0777
templates permissions = 0777

#1 mysql_connect(*********.** )
-> Connection OK!

#2 mysql_select_db( *********.** )
-> Database selection OK!

#3 mysql_query( SELECT * FROM `tbl_mlm_sub_req` WHERE `fld_sub` = '0' )
-> Query OK!

#4 mysql_query( SELECT * FROM `tbl_mlm_sub` WHERE `fld_list` = '' )
-> Query OK!

#5 mysql_query( SELECT * FROM `tbl_mlm_sub_clk` WHERE `fld_delivery` = '' )
-> Query OK!

#6 1 list(s), 5465 recipient(s), 446 deliveries
-> No error found.

Lists (List Name | Total Recipients | Modification Date):
list | 5465 | 2018-11-18 14:26:57
Any ideas what's wrong
 

stanbusk

Administrator
Staff member
You get an error but have you checked whether your list is actually transferred? There are servers that return an error even when everything went fine... By the way, your MLM diagnostic is ok!

--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 

dysong3

Member
I just did a test and verified that the error message I am getting is correct. Nothing gets uploaded. What's weird is that it "Upload to MLM…" worked for years without a hitch and we haven't changed providers or anything that I can think of.
 

stanbusk

Administrator
Staff member
Yes but your provider may have changed the PHP security settings. I would say there is 99,99% chances the problem comes from that, PHP security settings. I can't do nothing, you can't either. Only your server administrator can! :)

--
Follow maxprog.com on Facebook | Google+ | Linkedin | Twitter | YouTube
and keep up-to-date with the latest Max Programming updates!
 
Top