Some small issues/remarks after upgrading to 7.5.4

jamo

Member
After upgrading to 7.5.4 I have some remarks or issues:

In the Transaction window I used to select an account by tab-ing into the field and then use the arrow-down key a fixed number of times to place the focus on the correct amount. Then I use Tab to go to the next input field. The input field has changed into a dropdown listbox. When I Tab into the input filed, enter the first character of the account name and then use the arrow down key, I have to press it 2 times to go to the next account in the list. Now the tricky part comes: I always go to the next input filed with enter. If I do this now, the account that I highlighted with the arrow key is not selected, but the first in the dropdown list. I have to press Enter now to select the account. Very very annoying!!

After entering some text in the Remarks files in the Transaction Window I press Enter, but nothing happens. In the previous version the default button was pressed (Add) by hitting Enter.

In the Transaction window the contents of the dropdown list for accounts has changed. I always saw the accounts, grouped by category. This is gone now. Can I configure it somewhere to get it back?

The Transaction window is slower now than the previous version. I have MAcOSX 10.11.1 (El Capitan) on an 2011 iMac 27".
 

stanbusk

Administrator
Staff member
In the Transaction window I used to select an account by tab-ing into the field and then use the arrow-down key a fixed number of times to place the focus on the correct amount. Then I use Tab to go to the next input field. The input field has changed into a dropdown listbox. When I Tab into the input filed, enter the first character of the account name and then use the arrow down key, I have to press it 2 times to go to the next account in the list. Now the tricky part comes: I always go to the next input filed with enter. If I do this now, the account that I highlighted with the arrow key is not selected, but the first in the dropdown list. I have to press Enter now to select the account. Very very annoying!!
With 7.5.3 we used a custom system that no longer works because it was using old Carbon libraries. iCash 7.5.4 is 100% Cocoa, as a result we have to use standard Cocoa stuff. That includes ComboBox. The autocomplete works on a very similar way, you write text, it autocompletes, as soon as the text is what you want you press the tab key to go to the next field. If you press the down arrow, the list is displayed, you can navigate thru the list with the up and down arrow and when you want to select a line you press the 'Return' key. Then you can press the tab key to go to the next field. All that is standard Cocoa ComboBox behavior. Personally I find it better than before because now you can see the list and navigate thru it with your keyboard and the list takes when you have typed into account, that means, only entries starting with the text you have typed will be displayed. Note that if you are not sure what account to select you can right-click the ComboBox blue right part and get a contextual menu of all your accounts ordered by types and categories. What can we do to make you life better without modifying cocoa behaviors?
After entering some text in the Remarks files in the Transaction Window I press Enter, but nothing happens. In the previous version the default button was pressed (Add) by hitting Enter.
I believe your are confusing the 'Return' and 'Enter' keys. The 'Return' key is below the delete key, this is key to select an entry in a ComboBox control on Mac OS. The 'Enter' key in on the low right part of your keyboard, that key works as before, it allows you to enter a transaction from any field. I am talking about the Apple Extended keyboard. In other keyboards the equivalent is fn+return.
In the Transaction window the contents of the dropdown list for accounts has changed. I always saw the accounts, grouped by category. This is gone now. Can I configure it somewhere to get it back?
Now it is displayed in alphabetical order. This is a requirement to get autocomplete works properly. As I describer above you can always right-click the right blue part of the combobox to get an ordered contextual menu.
The Transaction window is slower now than the previous version. I have MacOSX 10.11.1 (El Capitan) on an 2011 iMac 27".
What do you mean with slower?
 

jamo

Member
With 7.5.3 we used a custom system that no longer works because it was using old Carbon libraries. iCash 7.5.4 is 100% Cocoa, as a result we have to use standard Cocoa stuff. That includes ComboBox. The autocomplete works on a very similar way, you write text, it autocompletes, as soon as the text is what you want you press the tab key to go to the next field. If you press the down arrow, the list is displayed, you can navigate thru the list with the up and down arrow and when you want to select a line you press the 'Return' key. Then you can press the tab key to go to the next field. All that is standard Cocoa ComboBox behavior.
Well, I think I have to get used to it then. It takes me twice the time, because I have to correct the account after entering the transaction. Explanation:
I have four accounts, all starting with "ABN-AMRO ", then followed by the account number (which I cannot/do not want to memorize). As said: I "tab-ed" into the input field, enter "ABN" and remembered that the third item was the correct account, so I pressed the down-arrow 3 times. Now I have to do it 4 times (first time is for expanding the listbox). The problem (for me) is that, after 9 years of using iCash, I am so used to using the Tab-key to go to the next input field, I keep doing this. Result is that the account I thought I selected, is not selected. I must use the return/enter key, and then press the Tab-key. Again: an extra "handling" or whatever you may call it.

I believe your are confusing the 'Return' and 'Enter' keys. The 'Return' key is below the delete key, this is key to select an entry in a ComboBox control on Mac OS. The 'Enter' key in on the low right part of your keyboard, that key works as before, it allows you to enter a transaction from any field. I am talking about the Apple Extended keyboard. In other keyboards the equivalent is fn+return.
Could be, but it used to work until 7.5.4 (the Return key). As said: I use iCash 9 years now and it is hard to break habbits. I think it is wrong, not to use the Return key anymore as a shortcut for pressing the "Add-button". In other applications this still works.

What do you mean with slower?
Maybe the better word is "sluggish"? It takes 1 or 2 seconds to respond. I was used to instant responds.

I just found another change in behavior: until this version, when you clicked into the "amount" field, to change an existing Transaction, all characters were selected and you could start typing the correct amount. Now, the cursor is placed before the number. I have to select the number first to overwrite it. It also can be 100 % Cocoa behavior, but it results in mistakes, followed by extra checking. In the end, I loose time (double!).
 

stanbusk

Administrator
Staff member
We are working on restoring previous behavior to iCash, new behavior is causing even bigger problem to Windows users. I will let you know when we are done.
 

jamo

Member
OK, I'll wait until that moment.

I found another issue with splitting a Transaction (not working). Do you want me to make a new Topic about it?
 

jamo

Member
Sorry for the late reaction. It's working now. Don't know why I couldn't enter the amount.

Next issues I found:

1. When I click on the "Planner" button (Dutch for Scheduler), the window opens in the top left corner. The buttons on that window cannot be seen and I cannot move the window. I had to install a special tool (BetterTouchTool) on my Mac to be able to use keyboard shortcuts to move the window.

2. After moving the Scheduler window, I add a new Transaction. I cannot enter an amount in the field; it is disabled.

3. When adding a new Account or modifying an existing Account, I cannot enter a value/amount; the field is disabled.
 

stanbusk

Administrator
Staff member
Weird, exact #1, all the problems you report have been fixed. Are you sure have downloaded iCash again from our server?
 

jamo

Member
I didn't realize I could download a new update. Checking the "Search for new versions" in iCash did not come up with a download hint ...

I downloaded the update and the last three issues are solved indeed.

This issue still remains and is very annoying:

I just found another change in behavior: until this version, when you clicked into the "amount" field, to change an existing Transaction, all characters were selected and you could start typing the correct amount. Now, the cursor is placed before the number. I have to select the number first to overwrite it. It also can be 100 % Cocoa behavior, but it results in mistakes, followed by extra checking. In the end, I loose time (double!).
 
Top