Problem with MAILTO tag with tracking on

SAW

Member
I too am having the problem of “[E-mail Address]localhost/” appearing instead of the actual email address, in the reply-to, subject, or body of an email generated by clicking mailto. This error occurs only when tracking is ON. Note, when I turn tracking OFF, it works correctly.

I installed MLM today via MBM 7.4. I then upgraded to MBM 7.5. Maybe, I should reinstall MLM from MBM 7.5 to get the fix? It sounds like you guys squared away the solution, but reading through this topic, I fail to see the answer. Please advise. Thanks, I really appreciate it.

about my system:
• I have MLM as Plain Text, not mySQL.
• MBM is set up to format as HTML only
• MBM 7.5
• Safari 4.0.3
• Mac Mail App 3.6
• Mac OS 10.5.8

Thanks for your help.
best, Stephen
 

SAW

Member
We are still having this problem:

“[E-mail Address]localhost/” appearing instead of just the actual email address, in the reply-to, subject, or body of an email generated by clicking mailto.

This error occurs only when tracking is ON. Note, when I turn tracking OFF, it works correctly.

Has there been any headway on what the solution is?
 

SAW

Member
Hi Stan.
Yes, we are using MBM 7.5

I reinstalled MLM from 7.5.
And this time I installed as mySQL (not as PlainText, like I had before.)
That said I still have MLM running as a Plain Text on another server (to use as a comparison test.)
The results from both mySQL and PlainText are the same (error still occurs: “[E-mail Address]localhost/” shows up where the email should be.)

The rest of my setup is:
• Safari 4.0.3
• Mac Mail App 3.6
• Mac OS 10.5.8

I ALSO get the same results on this system setup:
• Safari 4.0.4
• Mac Mail App 4.2
• Mac OS 10.6.3

more notes:
• MBM is set up to format as HTML only (yet when we switch to Text|HTML the error result remains.)


HERE IS MY TEST:

With tracking ON:

code:
Code:
<p><a href="mailto:johndoe@gmail.com?subject=[E-mail Address]">email address in subject</a></p>
result in subject field:
[E-mail Address]localhost/

code:
Code:
<p><a href="mailto:johndoe@gmail.com?Reply-To=[E-mail Address]">email address in reply to</a></p>
result in reply to field:
[E-mail Address]localhost/
code:
Code:
<p><a href="mailto:johndoe@gmail.com?subject=test&body=[E-mail Address]">email address in body</a></p>
result body email field:
[E-mail Address]localhost/

With tracking OFF:

It works correctly. With the email address being filled in, as expected.


*Please note that I have simplified this test above.*

Our traditional method of code is more complicated and looks like this:

With tracking ON:

code:
Code:
<p>if you are on our list multiple times, we can fix that for you, please click <a href="mailto:johndoe@gmail.com?subject=please%20update%20my%20contact%20info,%20thanks!&body=If%20you%20are%20on%20our%20email%20list%20multiple%20times%2C%20we%20can%20fix%20that%20for%20you%21%20%0A%0AThe%20email%20address%20we%20contacted%20you%20at%20was%3A%20[E-mail Address]%20%0A%0AWould%20you%20like%20us%20to%20unsubscribe%20that%20email%20address%2C%20or%20a%20different%20one%3F%20%0A%0A%0A">here</a></p>
result in body field:
If you are on our email list multiple times, we can fix that for you!

The email address we contacted you at was: [E-mail Address] \n\nWould you like us to unsubscribe that email address, or a different one? \n\n\nlocalhost/

With tracking OFF:

result in body field:

If you are on our email list multiple times, we can fix that for you!

The email address we contacted you at was: janedoe@gmail.com

Would you like us to unsubscribe that email address, or a different one?

Stan, I know this was a long winded reply. Just trying to give you as much intel as possible.

Thanks you for your looking into this. And btw, I am a long time satisfied customer. :D

best, Stephen
 

stanbusk

Administrator
Staff member
I can't reproduce your problem here in any way. Try to delete the MaxBulk Mailer preferences and enter them again. Perhaps those preferences are corrupt.
 
Top