MLM Won't Install Automatic or Manual


New Member
Hi Stan,

Thanks for your patience. I have found the problem ...

In my host server configuration mySQL resides on the same server as our website (where the MLM installs the 'lm' directory).

In a case such as this the mySQL Host Name must be 'localhost' ... not the DNS Name or IP address of the server.

If it's not already, it might be beneficial to add this info to the Installation Instructions, FAQ, and Help Files for those unfamiliar.

So the settings in the lm_settings.php file would be:

$dbhost = 'localhost'; // mySQL Host Name

I did not re-try the auto install, however after following the manual install instructions, making the change to 'localhost' (above), and running the Init command, the mySQL tables were created instantly.

Thanks again for all your help!