MLM Set up ?'s Mac


Hi Stan,

Hope all is well.

I recently switched over to a new hosting package and needed to re-install/set up new MLM in my directory.

Followed instructions and everything installed fine. However the information that I entered using the set-up in MBM/MLM did not make the changes to the lm_settings.php. I remembered having this issue before so I opened the lm_settings.php file in Textedit and filled in manually all the info. I've attached the file but changed private stuff too XXXXX but you'll get the idea.

The question I have is in the section STORAGE TYPE. It defaulted to 0. Should that be 1? I ran some tests and I seem to be getting the information I need in the statistic window in MBM with it set to 0.

I was initially having issues with MLM crashing, but solved that by changing http to https in Preferences>General> Remote List Stats. I have another question, but I'll start with this first.

Mac OS 11.6 MBM version 8.7.5 (have not updated yet)

Thanks. Jonathan


  • lm_settings.pdf
    24.5 KB · Views: 4
Last edited:


Staff member
Yes, it is recommended to set store type to 1, that is, MySQL. If it works with 0 it is because you were using text files to store the data. Storing to text files is an alternative when MySQL is not available on your server but should not be used if you do have MySQL since MySQL is much better. It is actually much faster, much more reliable, and way more secure.

MaxBulk Mailer doesn't support HTTP URLs indeed. On,ly HTTPS, even in messages.


Hi Stan.

Thanks for your response.

I changed the SQL to 1 as suggested. However I noticed that none of the hyperlinks in my email message were functioning properly. (Styled Text)

After clicking link in sent message, the page would start to load but then stall. It seemed to get stuck with something after by a whole string of numbers and letters).

I also noticed that the info in the Statistics window was not updating too.

I then changed the 1 back to 0, did another test, and not only do my links work, the corresponding information in the Statistics window show up, including the user "activated" clicked link info.

Weird. So I guess I'll keep my settings as is unless otherwise advised. I am getting the information I need.

Any ideas?



Staff member
You also have to enter your MySQL information on the very same file.

$dbhost              = 'MYSQL_SERVER_ADDRESS';              // mySQL Host Name (if you need to set the port add :portnum)
$dbusername          = 'USER_ID';                           // mySQL User Name (For Full access!!)
$dbuserpass          = 'PASSWORD';                          // mySQL User Password (For Full access!!)
$dbname              = 'DATABASE_NAME';                     // mySQL Database Name

You need to provide the MySQL server address, the database name, user name, and password.