• Next Maxprog online event is scheduled to go live soon!

    You can attend the event here: live.maxprog.com
    You can already ask questions on the very same page.

    You can also add the event to your calendar by clicking on Add to Calendar
    or click on the YouTube button to subscribe to our channel.
  • Customer ideas and suggestions are our fuel!

    To allow you to submit feature requests hassle-free we just created a Feature Request page.
    You can access it here: feedback.maxprog.com/

    That page gives you access to all the feature requests that have been submitted so far, and,
    + You can upvote feature requests
    + You can subscribe to feature requests
    + You can check a feature request status

Found a bug or something inconsistent!?!

widger

New Member
Hi,

First of all thank you for a great software :lol:

I have the Swedish version and my problem started
when I runned the checking data tool.

I have a checking account where I for example put in
1000,55 SEK from the beginning. I then had a transaction
from that account of 400,00 SEK. Balance is 600,55 SEK

When I run the checking data tool is says I have an error in that
account of 0,05 SEK and it want to fix the balance to 600,50 SEK???

I run a SQL query and saw that the Account_Opening is 1000,5 SEK
even though if I double click the checkings account it says opening
1000,55 SEK?!?!

Now I also have a unreconciled transaction of 0,05 which I can't find anywhere!?!?

/R
 

widger

New Member
Tested some more...

  • 1. I tried and did a new .icash file
    2. Added 17002,55 SEK to the checkings account by double clicking and changing the opening edit box to 17002,55 SEK
    3. Made a transaction of 4000SEK to wallet
    4. Run 'checking data' tool
    5. Reports an error an want to change the balance to 13002,50 instead of 13002,55 that is should be.
I think it may have something to do with that you aren't allow to add that
high presicion to the opening of an account. So 17002,55 is rounded to
17002,5 in the database.

/R
 

stanbusk

Administrator
Staff member
Precision is set by you thru the Preference panel, it can be from 0 to 10 decimals. Anyway, do you get correct result when using 17002,5 for the opening?
 

widger

New Member
The precision setting does not help at all, and yes when using 17002,50 there is no error in the "checking data" tool. The strange thing is that everything works when I have put 17002,55 in the opening. When I withdraw the 4000 the calculation works and it shows 13002,55. Its only when running the tool is fails.

hmmm... tested one thing just now. Same fault if I just.

1. Start new book (home account)
2. Double click checkingsaccount
3. Add 17002,55 to openings
4. Run "Checking data" tool.

->>> It says error and want to change checkingsaccount to 17002,50

FOUND THE PROBLEM!!!

If you add to openings and run "checking data" tool
0,55 -> ok
1,55 -> ok
10,55 -> ok
100,55 -> ok
1000,55 -> ok
10000,55 -> ERROR

Hope this helps.

/R
 

stanbusk

Administrator
Staff member
I discovered the problem. Actually the data checking tool contains an outdated line from old v1 that we forgot to update. Your file is right but data checking tool is wrong. Open a support ticket so I can send you a link to new version.
 
Top