Can't upload lists to SQL

kev

Member
Have MLM installed

If I create a new document, add some recipient data and then try to upload it, I get:


What's wrong?
 

kev

Member
I have all the lasts MLM and MBM files, but installed SQL a while back and did not continue to use it.

Is the file structure different? If so, how do I change it?
 

stanbusk

Administrator
Staff member
The version number is inside the 'lm.php' file. I ask for that number because you are reporting a problem that we fixed last month.
 

kev

Member
stanbusk said:
The version number is inside the 'lm.php' file. I ask for that number because you are reporting a problem that we fixed last month.
$script_name = "Maxprog List Manager";
$script_version = "3.0.7";
$copyright = "Copyright (c) 2008 - 2012";
$languages = array( 'en', 'fr', 'de', 'es', 'it', 'nl', 'cz' );
 

stanbusk

Administrator
Staff member
Ok, can you explain how are you uploading your list and what is the format of that list?
 

kev

Member
stanbusk said:
Ok, can you explain how are you uploading your list and what is the format of that list?
Open a blank document.
Add data in all named fields.
Try to upload it.

It fails as previously mentioned.
 

stanbusk

Administrator
Staff member
Do you mean you create a list in MaxBulk Mailer and then try to upload it? Are you use MLM is properly installed? Have you tried to log into MLM with your browser, add a list and add a recipient to it? Any error?
 

kev

Member
When I switch to SQL, I log in and try to create a new list, it says Server problem when reading list.

I got emails which says

Service unavailable!
:

Subject:
[MLM] mySQL Connect Error in SaveRequestToDB()

and

[MLM] mySQL Connect Error in RequestExistsInDB()
 

stanbusk

Administrator
Staff member
That means you SQL settings data in the lm_settings.php file are wrong. Check your account data with your web server support.
 

kev

Member
They are all correct as far as I can see.

$dbhost = 'cpanel17.uk2.net'; // mySQL Host Name (if you need to set the port add :portnum)
$dbusername = 'account username'; // mySQL User Name (For Full access!!)
$dbuserpass = 'my password'; // mySQL User Password (For Full access!!)
$dbname = 'username_mlm'
 

stanbusk

Administrator
Staff member
I have no way to know if your settings are good or not since settings are private to you and your server. The account has to have full privileges, read, write and table creation.
 
Top